用户工具

站点工具


irouter:net:vlan_passthrough

返回首页

企业网络VLAN穿透

三层交换机上划分有多个VLAN(也可以使用二层VLAN交换机),路由上创建对应的VLAN,路由LAN口接交换机的 trunk 口。

另外参考:企业VLAN网络三层转发

网络拓扑


路由上的配置


1. 在路由上创建和三层交换机对应的VLAN

进入“网络”-》“虚拟局域网 (VLAN)”-》“新增VLAN”

全部添加后,然后开启“VLAN (虚拟局域网) 功能”,如下:

最后,可以点击“VLAN状态”查看创建的VLAN的状态,确认VLAN创建成功

2. 配置DHCP,为每个VLAN分配IP

如果VLAN下面的客户机是固定IP或PPPoE拨号上网,此步可忽略.

进入“网络”-》“DHCP 服务”-》“IP地址池”-》“新建IP地址池”,

添加4条地址池规则(或点击”一键生成默认地址池“快速添加),最后的规则如下:

3. 配置PPPoE拨号服务,让VLAN下面的客户机可以通过PPPoE拨号上网(可选)

进入“应用”-》“PPPoE拨号服务”-》“参数配置”,在监听网络接口中,勾选所有的VLAN接口,然后保存设置即可

三层交换机上的配置


这里以H3C S5024 为例

vlan 10 20 30 40

## 默认VLAN1 IP 地址
interface Vlanif1
 ip address 172.16.0.1 255.255.255.0

## VLAN10 IP 地址
interface Vlanif10
 ip address 192.168.10.1 255.255.255.0

## VLAN20 IP 地址
interface Vlanif20
 ip address 192.168.30.1 255.255.255.0   

## VLAN30 IP 地址                                         
interface Vlanif30                        
 ip address 192.168.30.1 255.255.255.0   

## VLAN40 IP 地址                                         
interface Vlanif40                        
 ip address 192.168.40.1 255.255.255.0   

## 端口1-5 在VLAN-10中
#---------------------------------------
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
... 省略 ...
#
interface GigabitEthernet0/0/5
 port link-type access
 port default vlan 10
#---------------------------------------

## 端口6-10 在VLAN-20中
#---------------------------------------
interface GigabitEthernet0/0/6
 port link-type access
 port default vlan 20
#
... 省略 ...
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 20
#---------------------------------------

## 端口11-15 在VLAN-30中
#---------------------------------------
interface GigabitEthernet0/0/11
 port link-type access
 port default vlan 30
#
... 省略 ...
#
interface GigabitEthernet0/0/15
 port link-type access
 port default vlan 30
#---------------------------------------

## 端口16-20 在VLAN-40中
#---------------------------------------
interface GigabitEthernet0/0/16
 port link-type access
 port default vlan 40
#
... 省略 ...
#
interface GigabitEthernet0/0/20
 port link-type access
 port default vlan 40
#---------------------------------------

## 端口21~23 在默认VLAN1中
#---------------------------------------
#
interface GigabitEthernet0/0/21
... 省略 ...
#
interface GigabitEthernet0/0/23
#

## 端口24接路由的LAN口,端口模式为trunk口(允许所有VLAN访问)
#---------------------------------------
#
interface GigabitEthernet0/0/24
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094
#---------------------------------------

网络诊断及测试


1. 内网互通测试

使用任一一台电脑(IP设为和路由LAN口相同网段 172.16.0.X),

接入三层交换机的任一默认VLAN1端口(21-23口),进入路由Web-》“工具”-》“PING测试”,依次

  • PING 交换机的VLAN1的IP地址,如不通,检查交换机的vlan1接口ip设置
  • PING 交换机的其他各个VLAN(10~40)的IP地址, 如不通,检查路由上VLAN设置由是否正确,或交换机的vlan接口的ip设置
  • PING 交换机下某一VLAN下的客户机的IP,比如 VLAN10下的192.168.10.2,如果不通,检查交换机上的vlan设置是否正确

2. 访问外网测试

在VLAN下的客户机电脑上(比如VLAN10中的192.168.10.2),访问外网,如果不通,检查

  • 数字列表项目其网关是否设为路由LAN口对应VLAN的接口IP(192.168.10.254)

VLAN穿透方案的优缺点

优点:

  • 路由上的DHCP可以为VLAN下的客户机分配IP
  • VLAN 下的客户机可以通过PPPoE拨号穿透三层交换机到路由
  • 路由上可获得VLAN下客户机的MAC地址

缺点:VLAN 之间的互访需通过路由转发

另外参考:企业VLAN网络三层转发

irouter/net/vlan_passthrough.txt · 最后更改: 2020/07/28 23:21 由 muddyboot

Copyright © 2014-2020 版权所有 (MoreQuick Networs Co., Ltd. All rights reserved)
本系统由 秒开 iRouter & 在阿里云上强力驱动